$re = '/(?!www.(?:abc|def).test.com)(?=www.*\.test\..*com)^.+$/m';
$str = 'www.test.com
www.abc.test.com
www.def.test.com
www.ghi.test.com
www.nottest.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);