#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^Official Name:[ \t]*(.+)"
Local $sString = "`This is a code update`" & @CRLF & _
"" & @CRLF & _
"Official Name: 2011 New York City Electrical Code" & @CRLF & _
"" & @CRLF & _
"Code Tile Name:" & @CRLF & _
"" & @CRLF & _
"Reference: https://www.nyc.gov/site/buildings/codes/electrical-code.page" & @CRLF & _
"" & @CRLF & _
"Citation: §27-3024" & @CRLF & _
"" & @CRLF & _
"Doc Title: Local Law 39-2011, Local Law 99-2013, Local Law 39-2015" & @CRLF & _
"" & @CRLF & _
"Source Doc: https://www.nyc.gov/assets/buildings/pdf/ll39of2011_electrical_code.pdf" & @CRLF & _
"" & @CRLF & _
"Drive: https://drive.google.com/file/d/19Q0_G3VITpx0iCULtANMHqydAv0ZmvcF/view?usp=share_link" & @CRLF & _
"" & @CRLF & _
"Effective Date: November 19, 2013 " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"**SCTOMJ**"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")