// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^Official Name:[ \t]*(.+)").unwrap();
let string = "`This is a code update`
Official Name: 2011 New York City Electrical Code
Code Tile Name:
Reference: https://www.nyc.gov/site/buildings/codes/electrical-code.page
Citation: §27-3024
Doc Title: Local Law 39-2011, Local Law 99-2013, Local Law 39-2015
Source Doc: https://www.nyc.gov/assets/buildings/pdf/ll39of2011_electrical_code.pdf
Drive: https://drive.google.com/file/d/19Q0_G3VITpx0iCULtANMHqydAv0ZmvcF/view?usp=share_link
Effective Date: November 19, 2013
**SCTOMJ**";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}