$re = '/^Official Name:[ \t]*(.+)/m';
$str = '`This is a code update`
Official Name: 2011 New York City Electrical Code
Code Tile Name:
Reference: https://www.nyc.gov/site/buildings/codes/electrical-code.page
Citation: §27-3024
Doc Title: Local Law 39-2011, Local Law 99-2013, Local Law 39-2015
Source Doc: https://www.nyc.gov/assets/buildings/pdf/ll39of2011_electrical_code.pdf
Drive: https://drive.google.com/file/d/19Q0_G3VITpx0iCULtANMHqydAv0ZmvcF/view?usp=share_link
Effective Date: November 19, 2013
**SCTOMJ**';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);