use strict;
my $str = '`This is a code update`
Official Name: 2011 New York City Electrical Code
Code Tile Name:
Reference: https://www.nyc.gov/site/buildings/codes/electrical-code.page
Citation: §27-3024
Doc Title: Local Law 39-2011, Local Law 99-2013, Local Law 39-2015
Source Doc: https://www.nyc.gov/assets/buildings/pdf/ll39of2011_electrical_code.pdf
Drive: https://drive.google.com/file/d/19Q0_G3VITpx0iCULtANMHqydAv0ZmvcF/view?usp=share_link
Effective Date: November 19, 2013
**SCTOMJ**';
my $regex = qr/^Official Name:[ \t]*(.+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}