#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)(\w+) are good.*(I want \1)"
Local $sString = "apples are good" & @CRLF & _
"bananas are bad" & @CRLF & _
"oranges are good" & @CRLF & _
"" & @CRLF & _
"I want oranges" & @CRLF & _
"I want bananas" & @CRLF & _
"I want apples" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")