re = /(\w+) are good.*(I want \1)/m
str = 'apples are good
bananas are bad
oranges are good
I want oranges
I want bananas
I want apples
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end