$re = '/(\w+) are good.*(I want \1)/ms';
$str = 'apples are good
bananas are bad
oranges are good
I want oranges
I want bananas
I want apples
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);