import re
regex = re.compile(r"(\w+) are good.*(I want \1)", flags=re.MULTILINE | re.DOTALL)
test_str = ("apples are good\n"
"bananas are bad\n"
"oranges are good\n\n"
"I want oranges\n"
"I want bananas\n"
"I want apples\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")