#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-z0-9][a-z0-9\-]*$"
Local $sString = "big-bang-single-package-demo" & @CRLF & _
"zarfofficialnipackage" & @CRLF & _
"cli-test" & @CRLF & _
"bad_name" & @CRLF & _
"<invalid=chars" & @CRLF & _
"-cannot-start-with-hyphen" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")