$re = '`^[a-z0-9][a-z0-9\-]*$`m';
$str = 'big-bang-single-package-demo
zarfofficialnipackage
cli-test
bad_name
<invalid=chars
-cannot-start-with-hyphen
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);