import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-z0-9][a-z0-9\\-]*$";
final String string = "big-bang-single-package-demo\n"
+ "zarfofficialnipackage\n"
+ "cli-test\n"
+ "bad_name\n"
+ "<invalid=chars\n"
+ "-cannot-start-with-hyphen\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}