package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-z0-9][a-z0-9\-]*$`)
var str = `big-bang-single-package-demo
zarfofficialnipackage
cli-test
bad_name
<invalid=chars
-cannot-start-with-hyphen
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}