#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(.{10}).*+\r?\n(?=\1)"
Local $sString = "12345 Dennis Yancey University of Miami" & @CRLF & _
"12345 Dennis Yancey University of Milan" & @CRLF & _
"12345 Dennis Yancey University of Rome" & @CRLF & _
"12344 Ryan Gardner University of Spain" & @CRLF & _
"12347 Smith John University of Canada" & @CRLF & _
"12347 Smith John University of Canada"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)