import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.{10}).*+\\r?\\n(?=\\1)";
final String string = "12345 Dennis Yancey University of Miami\n"
+ "12345 Dennis Yancey University of Milan\n"
+ "12345 Dennis Yancey University of Rome\n"
+ "12344 Ryan Gardner University of Spain\n"
+ "12347 Smith John University of Canada\n"
+ "12347 Smith John University of Canada";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}