const regex = /^(.{10}).*+\r?\n(?=\1)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.{10}).*+\\r?\\n(?=\\1)', 'gm')
const str = `12345 Dennis Yancey University of Miami
12345 Dennis Yancey University of Milan
12345 Dennis Yancey University of Rome
12344 Ryan Gardner University of Spain
12347 Smith John University of Canada
12347 Smith John University of Canada`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);