re = /^(.{10}).*+\r?\n(?=\1)/m
str = '12345 Dennis Yancey University of Miami
12345 Dennis Yancey University of Milan
12345 Dennis Yancey University of Rome
12344 Ryan Gardner University of Spain
12347 Smith John University of Canada
12347 Smith John University of Canada'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result