#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[^0-9]([0-9]{6}-[0-9])[^0-9]"
Local $sString = "asdf 123456-7 asdf" & @CRLF & _
"asdf123456-7asdf" & @CRLF & _
"asdf 112423456-7 asdf" & @CRLF & _
"asdf,123456-7,asdf" & @CRLF & _
"123456-7" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")