import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^0-9]([0-9]{6}-[0-9])[^0-9]";
final String string = "asdf 123456-7 asdf\n"
+ "asdf123456-7asdf\n"
+ "asdf 112423456-7 asdf\n"
+ "asdf,123456-7,asdf\n"
+ "123456-7\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}