re = /[^0-9]([0-9]{6}-[0-9])[^0-9]/m
str = 'asdf 123456-7 asdf
asdf123456-7asdf
asdf 112423456-7 asdf
asdf,123456-7,asdf
123456-7
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end