import re
regex = re.compile(r"[^0-9]([0-9]{6}-[0-9])[^0-9]", flags=re.MULTILINE)
test_str = ("asdf 123456-7 asdf\n"
"asdf123456-7asdf\n"
"asdf 112423456-7 asdf\n"
"asdf,123456-7,asdf\n"
"123456-7\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")