import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "changed[\\S\\s]*?replicas";
final String string = "test, test-xxx-a2, Deployment (apps) has changed:\n"
+ "...\n"
+ "- value: 4.x.x\n"
+ "+ value: x.3.x\n"
+ "...\n"
+ "test, test-xxxio-3, Deployment (apps) has changed:\n"
+ "...\n"
+ "- replicas: 3\n"
+ "+ replicas: 5\n"
+ "...\n\n"
+ "test, test-xxx-xxx, Deployment (apps) has changed:\n"
+ "...\n"
+ "- value: x.2.x\n"
+ "+ value: x.x.x\n"
+ "...\n"
+ "test, test-xxxio-1, Deployment (apps) has changed:\n"
+ "...\n"
+ "- replicas: 3\n"
+ "+ replicas: 5\n"
+ "...\n\n"
+ "test, test-xxxio-4, Deployment (apps) has add:\n"
+ "...\n\n"
+ "text...\n\n"
+ "...\n\n"
+ "test, test-xxx-test2, Deployment (apps) has changed:\n"
+ "...\n"
+ "- replicas: 3\n"
+ "+ replicas: 2\n"
+ "...";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}