$re = '/changed[\S\s]*?replicas/';
$str = 'test, test-xxx-a2, Deployment (apps) has changed:
...
- value: 4.x.x
+ value: x.3.x
...
test, test-xxxio-3, Deployment (apps) has changed:
...
- replicas: 3
+ replicas: 5
...
test, test-xxx-xxx, Deployment (apps) has changed:
...
- value: x.2.x
+ value: x.x.x
...
test, test-xxxio-1, Deployment (apps) has changed:
...
- replicas: 3
+ replicas: 5
...
test, test-xxxio-4, Deployment (apps) has add:
...
text...
...
test, test-xxx-test2, Deployment (apps) has changed:
...
- replicas: 3
+ replicas: 2
...';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);