import re
regex = re.compile(r"changed[\S\s]*?replicas")
test_str = ("test, test-xxx-a2, Deployment (apps) has changed:\n"
"...\n"
"- value: 4.x.x\n"
"+ value: x.3.x\n"
"...\n"
"test, test-xxxio-3, Deployment (apps) has changed:\n"
"...\n"
"- replicas: 3\n"
"+ replicas: 5\n"
"...\n\n"
"test, test-xxx-xxx, Deployment (apps) has changed:\n"
"...\n"
"- value: x.2.x\n"
"+ value: x.x.x\n"
"...\n"
"test, test-xxxio-1, Deployment (apps) has changed:\n"
"...\n"
"- replicas: 3\n"
"+ replicas: 5\n"
"...\n\n"
"test, test-xxxio-4, Deployment (apps) has add:\n"
"...\n\n"
"text...\n\n"
"...\n\n"
"test, test-xxx-test2, Deployment (apps) has changed:\n"
"...\n"
"- replicas: 3\n"
"+ replicas: 2\n"
"...")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")