// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"changed[\S\s]*?replicas").unwrap();
let string = "test, test-xxx-a2, Deployment (apps) has changed:
...
- value: 4.x.x
+ value: x.3.x
...
test, test-xxxio-3, Deployment (apps) has changed:
...
- replicas: 3
+ replicas: 5
...
test, test-xxx-xxx, Deployment (apps) has changed:
...
- value: x.2.x
+ value: x.x.x
...
test, test-xxxio-1, Deployment (apps) has changed:
...
- replicas: 3
+ replicas: 5
...
test, test-xxxio-4, Deployment (apps) has add:
...
text...
...
test, test-xxx-test2, Deployment (apps) has changed:
...
- replicas: 3
+ replicas: 2
...";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}