using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?<!-)attorney(?!-)\b";
string input = @"attorney
attorney cat
construction-law
assistant-attorney
assistant attorney
attorneys and fakewordwithattorneyinit
My assistant-attorney wil see you now
The attorney-general was her
my attorney will be calling you";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}