import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?<!-)attorney(?!-)\\b";
final String string = "attorney \n"
+ "attorney cat\n"
+ "construction-law \n"
+ "assistant-attorney \n"
+ "assistant attorney\n"
+ "attorneys and fakewordwithattorneyinit\n"
+ "My assistant-attorney wil see you now\n"
+ "The attorney-general was her\n"
+ "my attorney will be calling you";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}