using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!printf[^\n]*)""(?![^""\n]*printf)[^""\n]{5,}""(?![^\n]*printf)";
string input = @"""Match"":
write(""blueberry""); // yum
y = 34; write(""banana"")
z = ""pineapple"";
Not match:
p = ""seed"";
printf(""-%s-"", ""strawberry""); // whatever
x = 12; printf(""lime""); write(""coconut"")
x = 12;"""" write(""coconut""); printf(""lime"");
write(""lime""); write(""lime"");
write(""lime""); write(""abc printf abc""); write(""lime"");
write(""lime""); write(""abc printf""); write(""lime"");
write(""lime""); write(""p printf""); write(""lime"");
write(""lime""); write(""pineapple printf""); write(""lime"");
write(""lime""); write("" printf""); write(""lime"");
write(""lime""); write(""printf abc""); write(""lime"");
write(""lime""); write(""printf""); write(""lime"");
write(printf""blueberry""); // yum
write(""blueberry""printf); // yum
write(""blueberry""); printf // yum
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}