const regex = /(?<!printf[^\n]*)"(?![^"\n]*printf)[^"\n]{5,}"(?![^\n]*printf)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!printf[^\\n]*)"(?![^"\\n]*printf)[^"\\n]{5,}"(?![^\\n]*printf)', 'gm')
const str = `"Match":
write("blueberry"); // yum
y = 34; write("banana")
z = "pineapple";
Not match:
p = "seed";
printf("-%s-", "strawberry"); // whatever
x = 12; printf("lime"); write("coconut")
x = 12;"""" write("coconut"); printf("lime");
write("lime"); write("lime");
write("lime"); write("abc printf abc"); write("lime");
write("lime"); write("abc printf"); write("lime");
write("lime"); write("p printf"); write("lime");
write("lime"); write("pineapple printf"); write("lime");
write("lime"); write(" printf"); write("lime");
write("lime"); write("printf abc"); write("lime");
write("lime"); write("printf"); write("lime");
write(printf"blueberry"); // yum
write("blueberry"printf); // yum
write("blueberry"); printf // yum
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}