use strict;
my $str = '"Match":
write("blueberry"); // yum
y = 34; write("banana")
z = "pineapple";
Not match:
p = "seed";
printf("-%s-", "strawberry"); // whatever
x = 12; printf("lime"); write("coconut")
x = 12;"""" write("coconut"); printf("lime");
write("lime"); write("lime");
write("lime"); write("abc printf abc"); write("lime");
write("lime"); write("abc printf"); write("lime");
write("lime"); write("p printf"); write("lime");
write("lime"); write("pineapple printf"); write("lime");
write("lime"); write(" printf"); write("lime");
write("lime"); write("printf abc"); write("lime");
write("lime"); write("printf"); write("lime");
write(printf"blueberry"); // yum
write("blueberry"printf); // yum
write("blueberry"); printf // yum
';
my $regex = qr/(?<!printf[^\n]*)"(?![^"\n]*printf)[^"\n]{5,}"(?![^\n]*printf)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}