import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!printf[^\\n]*)\"(?![^\"\\n]*printf)[^\"\\n]{5,}\"(?![^\\n]*printf)";
final String string = "\"Match\":\n"
+ "write(\"blueberry\"); // yum\n"
+ "y = 34; write(\"banana\")\n"
+ "z = \"pineapple\";\n\n\n\n\n"
+ "Not match:\n"
+ "p = \"seed\";\n"
+ "printf(\"-%s-\", \"strawberry\"); // whatever\n"
+ "x = 12; printf(\"lime\"); write(\"coconut\")\n"
+ "x = 12;\"\"\"\" write(\"coconut\"); printf(\"lime\");\n"
+ "write(\"lime\"); write(\"lime\");\n"
+ "write(\"lime\"); write(\"abc printf abc\"); write(\"lime\");\n"
+ "write(\"lime\"); write(\"abc printf\"); write(\"lime\");\n"
+ "write(\"lime\"); write(\"p printf\"); write(\"lime\");\n"
+ "write(\"lime\"); write(\"pineapple printf\"); write(\"lime\");\n"
+ "write(\"lime\"); write(\" printf\"); write(\"lime\");\n"
+ "write(\"lime\"); write(\"printf abc\"); write(\"lime\");\n"
+ "write(\"lime\"); write(\"printf\"); write(\"lime\");\n"
+ "write(printf\"blueberry\"); // yum\n"
+ "write(\"blueberry\"printf); // yum\n"
+ "write(\"blueberry\"); printf // yum\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}