#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<(?<log_level>[^>]+)>\s+<(?<class>[^>]+)>\s+<(?<hostname>[^>]+)>\s+<(?<viewname>[^>]+)>\s+<(?<unknown1>[^>].)?>\s+<(?<exec_process>[^>]+)>\s+<requestId=(?<Req_ID>[^>]+)>\s+<(?<unknown2>[^>]+)?>\s+<clientIp=(?<Cust_IP>[^\"]+)\">\"(?<log_class>[^:].+):(?<App_Name>[^\ ]+)"
Local $sString = "<ERROR> <store.view.app.api.controller.myClientLoggingController> <viewhost02> <myview2_2> <> <catalina-exec-7> <requestId=d4s6666-9d6e-2c0g-7c20-6e9f7wfa7f6> <> <clientIp=234.234.234.22">"store.view.app.api.controller.myClientLoggingController.logError(?:?):My-AngularApp" & @CRLF & _
"xxxxxxxxxxxxxxxxxxxxxxxxxxxxxcxxxxxxxxxxxx"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")