re = /<(?<log_level>[^>]+)>\s+<(?<class>[^>]+)>\s+<(?<hostname>[^>]+)>\s+<(?<viewname>[^>]+)>\s+<(?<unknown1>[^>].)?>\s+<(?<exec_process>[^>]+)>\s+<requestId=(?<Req_ID>[^>]+)>\s+<(?<unknown2>[^>]+)?>\s+<clientIp=(?<Cust_IP>[^\"]+)\">\"(?<log_class>[^:].+):(?<App_Name>[^\ ]+)/m
str = '<ERROR> <store.view.app.api.controller.myClientLoggingController> <viewhost02> <myview2_2> <> <catalina-exec-7> <requestId=d4s6666-9d6e-2c0g-7c20-6e9f7wfa7f6> <> <clientIp=234.234.234.22">"store.view.app.api.controller.myClientLoggingController.logError(?:?):My-AngularApp
xxxxxxxxxxxxxxxxxxxxxxxxxxxxxcxxxxxxxxxxxx'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end