import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<(?<log_level>[^>]+)>\\s+<(?<class>[^>]+)>\\s+<(?<hostname>[^>]+)>\\s+<(?<viewname>[^>]+)>\\s+<(?<unknown1>[^>].)?>\\s+<(?<exec_process>[^>]+)>\\s+<requestId=(?<Req_ID>[^>]+)>\\s+<(?<unknown2>[^>]+)?>\\s+<clientIp=(?<Cust_IP>[^\\\"]+)\\\">\\\"(?<log_class>[^:].+):(?<App_Name>[^\\ ]+)";
final String string = "<ERROR> <store.view.app.api.controller.myClientLoggingController> <viewhost02> <myview2_2> <> <catalina-exec-7> <requestId=d4s6666-9d6e-2c0g-7c20-6e9f7wfa7f6> <> <clientIp=234.234.234.22\">\"store.view.app.api.controller.myClientLoggingController.logError(?:?):My-AngularApp\n"
+ "xxxxxxxxxxxxxxxxxxxxxxxxxxxxxcxxxxxxxxxxxx";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}