const regex = /<(?<log_level>[^>]+)>\s+<(?<class>[^>]+)>\s+<(?<hostname>[^>]+)>\s+<(?<viewname>[^>]+)>\s+<(?<unknown1>[^>].)?>\s+<(?<exec_process>[^>]+)>\s+<requestId=(?<Req_ID>[^>]+)>\s+<(?<unknown2>[^>]+)?>\s+<clientIp=(?<Cust_IP>[^\"]+)\">\"(?<log_class>[^:].+):(?<App_Name>[^\ ]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<(?<log_level>[^>]+)>\\s+<(?<class>[^>]+)>\\s+<(?<hostname>[^>]+)>\\s+<(?<viewname>[^>]+)>\\s+<(?<unknown1>[^>].)?>\\s+<(?<exec_process>[^>]+)>\\s+<requestId=(?<Req_ID>[^>]+)>\\s+<(?<unknown2>[^>]+)?>\\s+<clientIp=(?<Cust_IP>[^\\"]+)\\">\\"(?<log_class>[^:].+):(?<App_Name>[^\\ ]+)', 'gm')
const str = `<ERROR> <store.view.app.api.controller.myClientLoggingController> <viewhost02> <myview2_2> <> <catalina-exec-7> <requestId=d4s6666-9d6e-2c0g-7c20-6e9f7wfa7f6> <> <clientIp=234.234.234.22">"store.view.app.api.controller.myClientLoggingController.logError(?:?):My-AngularApp
xxxxxxxxxxxxxxxxxxxxxxxxxxxxxcxxxxxxxxxxxx`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}