#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?!^\s|[ \-']{2}|[\d\r\n\t\f\v!"#$%&()*+,\.\/:;<=>?@[\\\]^_`{|}~€‚ƒ„…†‡ˆ‰‹‘’“”•–—˜™›¡¢£¤¥¦§¨©ª«¬®¯°±²³´¶·¸¹º»¼½¾¿×÷№′″ⁿ⁺⁰‱₁₂₃₄]|\s$).){1,50}$"
Local $sString = "Regex matches: from 1 to 50 international letters separated by single delimiter ( -')" & @CRLF & _
"Regex rejects: empty prefix/suffix, consecutive delimiters ( -'), digits, new line, tab, limited list of extended ASCII characters" & @CRLF & _
"" & @CRLF & _
"Jo Nesbø" & @CRLF & _
"Pedro Almodóvar" & @CRLF & _
"بيدرو ألمودوبار" & @CRLF & _
"Sofija Jogailaitė" & @CRLF & _
"Akira Kurosawa" & @CRLF & _
"Куросава Акіра" & @CRLF & _
"Куросава Акира" & @CRLF & _
"黒澤明" & @CRLF & _
"黑澤明" & @CRLF & _
"আকিৰা কুৰোছাৱা" & @CRLF & _
"Tyue' Tgshh" & @CRLF & _
"CxCx5C5C" & @CRLF & _
"AKIRA KUROSAWA" & @CRLF & _
"Akir@ Kursawa" & @CRLF & _
"Stev3 Smith" & @CRLF & _
"STeve Smith" & @CRLF & _
"Steve SMith" & @CRLF & _
"Steve Sm1th" & @CRLF & _
"Steve G. Smith" & @CRLF & _
"d'Are to Beaware" & @CRLF & _
"Hyoung Kyoung Wu" & @CRLF & _
"Mike O'Neal" & @CRLF & _
"Steve Johnson-Smith" & @CRLF & _
"Jozef-Schmozev Hiemdel" & @CRLF & _
"O Henry Smith" & @CRLF & _
"Mathais d'Arras" & @CRLF & _
"Martin Luther King Jr" & @CRLF & _
"Downtown-James Brown" & @CRLF & _
"Darren McCarty" & @CRLF & _
"An Ni" & @CRLF & _
"O. Henry McCarty" & @CRLF & _
"George De FunkMaster" & @CRLF & _
"Kurtis B-Ball" & @CRLF & _
"Ahmad el Jeffe" & @CRLF & _
"John Smith" & @CRLF & _
"'John Smith"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")