import re
regex = re.compile(r"^(?:(?!^\s|[ \-']{2}|[\d\r\n\t\f\v!\"#$%&()*+,\.\/:;<=>?@[\\\]^_`{|}~€‚ƒ„…†‡ˆ‰‹‘’“”•–—˜™›¡¢£¤¥¦§¨©ª«¬®¯°±²³´¶·¸¹º»¼½¾¿×÷№′″ⁿ⁺⁰‱₁₂₃₄]|\s$).){1,50}$", flags=re.MULTILINE)
test_str = ("Regex matches: from 1 to 50 international letters separated by single delimiter ( -')\n"
"Regex rejects: empty prefix/suffix, consecutive delimiters ( -'), digits, new line, tab, limited list of extended ASCII characters\n\n"
"Jo Nesbø\n"
"Pedro Almodóvar\n"
"بيدرو ألمودوبار\n"
"Sofija Jogailaitė\n"
"Akira Kurosawa\n"
"Куросава Акіра\n"
"Куросава Акира\n"
"黒澤明\n"
"黑澤明\n"
"আকিৰা কুৰোছাৱা\n"
"Tyue' Tgshh\n"
"CxCx5C5C\n"
"AKIRA KUROSAWA\n"
"Akir@ Kursawa\n"
"Stev3 Smith\n"
"STeve Smith\n"
"Steve SMith\n"
"Steve Sm1th\n"
"Steve G. Smith\n"
"d'Are to Beaware\n"
"Hyoung Kyoung Wu\n"
"Mike O'Neal\n"
"Steve Johnson-Smith\n"
"Jozef-Schmozev Hiemdel\n"
"O Henry Smith\n"
"Mathais d'Arras\n"
"Martin Luther King Jr\n"
"Downtown-James Brown\n"
"Darren McCarty\n"
"An Ni\n"
"O. Henry McCarty\n"
"George De FunkMaster\n"
"Kurtis B-Ball\n"
"Ahmad el Jeffe\n"
"John Smith\n"
"'John Smith")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")