use strict;
my $str = 'Regex matches: from 1 to 50 international letters separated by single delimiter ( -\')
Regex rejects: empty prefix/suffix, consecutive delimiters ( -\'), digits, new line, tab, limited list of extended ASCII characters
Jo Nesbø
Pedro Almodóvar
بيدرو ألمودوبار
Sofija Jogailaitė
Akira Kurosawa
Куросава Акіра
Куросава Акира
黒澤明
黑澤明
আকিৰা কুৰোছাৱা
Tyue\' Tgshh
CxCx5C5C
AKIRA KUROSAWA
Akir@ Kursawa
Stev3 Smith
STeve Smith
Steve SMith
Steve Sm1th
Steve G. Smith
d\'Are to Beaware
Hyoung Kyoung Wu
Mike O\'Neal
Steve Johnson-Smith
Jozef-Schmozev Hiemdel
O Henry Smith
Mathais d\'Arras
Martin Luther King Jr
Downtown-James Brown
Darren McCarty
An Ni
O. Henry McCarty
George De FunkMaster
Kurtis B-Ball
Ahmad el Jeffe
John Smith
\'John Smith';
my $regex = qr/^(?:(?!^\s|[ \-']{2}|[\d\r\n\t\f\v!"#$%&()*+,\.\/:;<=>?@[\\\]^_`{|}~€‚ƒ„…†‡ˆ‰‹‘’“”•–—˜™›¡¢£¤¥¦§¨©ª«¬®¯°±²³´¶·¸¹º»¼½¾¿×÷№′″ⁿ⁺⁰‱₁₂₃₄]|\s$).){1,50}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}