import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^question\\s+(\\d+),\\s+chapter\\s+(\\d+)(?!(?:\\n(?!question |solution ).*)*\\nsolution for question \\1)";
final String string = "question 1, chapter 1\n"
+ "...\n"
+ "solution for question 1, chapter 1\n"
+ "...\n"
+ "question 2, chapter 1\n"
+ "...\n"
+ "solution for question 2, chapter 1\n"
+ "...\n"
+ "question 3, chapter 1\n"
+ "...\n"
+ "question 4, chapter 1\n"
+ "...\n"
+ "solution for question 4, chapter 1\n\n"
+ "question 5, chapter 1\n"
+ "...\n"
+ "solution for question 5, chapter 1\n\n"
+ "question 6, chapter 1\n\n"
+ "question 7, chapter 1\n"
+ "...\n"
+ "solution for question 7, chapter 1\n\n"
+ "question 3, chapter 1\n\n"
+ "question 4, chapter 1\n\n"
+ "question 6, chapter 1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}