const regex = /^question\s+(\d+),\s+chapter\s+(\d+)(?!(?:\n(?!question |solution ).*)*\nsolution for question \1)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^question\\s+(\\d+),\\s+chapter\\s+(\\d+)(?!(?:\\n(?!question |solution ).*)*\\nsolution for question \\1)', 'gm')
const str = `question 1, chapter 1
...
solution for question 1, chapter 1
...
question 2, chapter 1
...
solution for question 2, chapter 1
...
question 3, chapter 1
...
question 4, chapter 1
...
solution for question 4, chapter 1
question 5, chapter 1
...
solution for question 5, chapter 1
question 6, chapter 1
question 7, chapter 1
...
solution for question 7, chapter 1
question 3, chapter 1
question 4, chapter 1
question 6, chapter 1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}