$re = '/^question\s+(\d+),\s+chapter\s+(\d+)(?!(?:\n(?!question |solution ).*)*\nsolution for question \1)/m';
$str = 'question 1, chapter 1
...
solution for question 1, chapter 1
...
question 2, chapter 1
...
solution for question 2, chapter 1
...
question 3, chapter 1
...
question 4, chapter 1
...
solution for question 4, chapter 1
question 5, chapter 1
...
solution for question 5, chapter 1
question 6, chapter 1
question 7, chapter 1
...
solution for question 7, chapter 1
question 3, chapter 1
question 4, chapter 1
question 6, chapter 1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);