import Foundation
let pattern = #"^question\s+(\d+),\s+chapter\s+(\d+)(?!(?:\n(?!question |solution ).*)*\nsolution for question \1)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
question 1, chapter 1
...
solution for question 1, chapter 1
...
question 2, chapter 1
...
solution for question 2, chapter 1
...
question 3, chapter 1
...
question 4, chapter 1
...
solution for question 4, chapter 1
question 5, chapter 1
...
solution for question 5, chapter 1
question 6, chapter 1
question 7, chapter 1
...
solution for question 7, chapter 1
question 3, chapter 1
question 4, chapter 1
question 6, chapter 1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)