package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(Ch[0-9]+:|Chapter [0-9]+, Part [0-9]+|Ch. [0-9]+|Ch[0-9]+)`)
var str = `Chapter 3: Ch3: It's Very Knife to Meet You
Chapter 11: Ch9, Part 2: Well, Isn't That Just Super Awesome
Chapter 25: Ch. 20: The Intro to a Horror Vid
Chapter 31: Ch25: There's a Lot to Unpack Here`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}