import re
regex = re.compile(r"(Ch[0-9]+:|Chapter [0-9]+, Part [0-9]+|Ch. [0-9]+|Ch[0-9]+)", flags=re.MULTILINE)
test_str = ("Chapter 3: Ch3: It's Very Knife to Meet You\n"
"Chapter 11: Ch9, Part 2: Well, Isn't That Just Super Awesome\n"
"Chapter 25: Ch. 20: The Intro to a Horror Vid\n"
"Chapter 31: Ch25: There's a Lot to Unpack Here")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")