const regex = new RegExp('(Ch[0-9]+:|Chapter [0-9]+, Part [0-9]+|Ch. [0-9]+|Ch[0-9]+)', 'gm')
const str = `Chapter 3: Ch3: It's Very Knife to Meet You
Chapter 11: Ch9, Part 2: Well, Isn't That Just Super Awesome
Chapter 25: Ch. 20: The Intro to a Horror Vid
Chapter 31: Ch25: There's a Lot to Unpack Here`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}