re = /(Ch[0-9]+:|Chapter [0-9]+, Part [0-9]+|Ch. [0-9]+|Ch[0-9]+)/m
str = 'Chapter 3: Ch3: It\'s Very Knife to Meet You
Chapter 11: Ch9, Part 2: Well, Isn\'t That Just Super Awesome
Chapter 25: Ch. 20: The Intro to a Horror Vid
Chapter 31: Ch25: There\'s a Lot to Unpack Here'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end