using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\()\d\d-?\d\d.*?(?=\))";
string input = @"random text here (00-04) more random text
lame text (junk data) more text (08-12)
random text (2008)
random text (2005) junk text (junk)
nothing important (13-15) not important (not important)
nothing important (13-15 text) not important (not important)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}