const regex = new RegExp('(?<=\\()\\d\\d-?\\d\\d.*?(?=\\))', 'g')
const str = `random text here (00-04) more random text
lame text (junk data) more text (08-12)
random text (2008)
random text (2005) junk text (junk)
nothing important (13-15) not important (not important)
nothing important (13-15 text) not important (not important)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}