use strict;
my $str = 'random text here (00-04) more random text
lame text (junk data) more text (08-12)
random text (2008)
random text (2005) junk text (junk)
nothing important (13-15) not important (not important)
nothing important (13-15 text) not important (not important)';
my $regex = qr/(?<=\()\d\d-?\d\d.*?(?=\))/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}