import re
regex = re.compile(r"^[^0-3][0-9]{7}", flags=re.MULTILINE)
test_str = ("91234567\n"
"81234567\n"
"71234567\n"
"61234567\n"
"51234567\n"
"41234567\n"
"31234567\n"
"21234567\n"
"11234567\n"
"01234567")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")